Bootloop and Minix not revealed when connected via USB

#1
My NEO X7 is stuck at the Minix logo when I try to boot it, so I am trying to flash the firmware but I cannot connect the Minix to the PC.

I have tried the following:
- Connect with a generic USB TypeA male - male cable to Linux, Win7, Win10
- Connect with standard MicroUSB cable (on OTG port) to Linux, Win7, Win10

Using lsusb on Linux the device does not appear.
In Windows the device is does not appear as well (not even as unrecognized device).

I have tried the following guide, but Windows does find the device so even installing the drivers nothing works. I think I am using the wrong cable.
https://theminixforum.com/index.php...ions-for-manually-installing-the-firmware.88/

What kind of cable/connection do I need?
Do I need the microUSB to USB Type A female that came in the box? (OTG port <--> MicroUSB-USB TypeA Female <--> USB TypeA Male - USB TypeA Male <--> PC )
What OS are supported?
 
#2
You have to use the microUSB to type A cable that came with the box. If you lost it, you have to cut out some plastic on the standard microUSB to type A to release more metal part, otherwise it can't make contact with the plug inside the box.


Win8 and 10 don't recognize the box in my experience so I highly recommend you using Win7 to flash firmware.
 
Top