bricked x7, please help!

#1
Hi, hoping someone can help me with neo x7 refusing to be flashed from batchtool 1.8. I must of tried 20-30 times by now and it fails at the "checking firmware" step every time. im using the official firmware from here so i know thats good, the box in batchtool lights up green so its in flash mode and it passes all the stages prior to the last one. honestly any help would be really appreciated, the box itself is sending no signal to the tv and the blue led no longer lights so im guessing its been completely wiped, the red led for the optical connector still lights. thanks in advance.

Capture.PNG
 
#2
Hi, hoping someone can help me with neo x7 refusing to be flashed from batchtool 1.8. I must of tried 20-30 times by now and it fails at the "checking firmware" step every time. im using the official firmware from here so i know thats good, the box in batchtool lights up green so its in flash mode and it passes all the stages prior to the last one. honestly any help would be really appreciated, the box itself is sending no signal to the tv and the blue led no longer lights so im guessing its been completely wiped, the red led for the optical connector still lights. thanks in advance.

View attachment 396
Please contact our customer support team at: support@minix.com.hk
 
#7
I had the exact same issue and I figured out a way to resolve it.

1. Make sure the device is powered off
2. Connect the device to PC (windows 7) with proper cabe via the OTG port
3. Press and hold the recovery button, then the power button
4. Click the Restore button in the Batch Tool as soon as the light turns green
5. Important: Keep holding both recovery buton + power button, it will pass the Checking firmware stage and the light will turn purple
6. Release both buttons and disconnect the device. You can now reconnect it and flash the firmware normally (no need to hold both button through out the process)
 
Top