CoreElec, Putty and SSH

#1
Ok, I am trying to install CoreElec onto the U9-H's internal ROM from SD card. I have downloaded the latest Putty for windows (0.70). When I start putty it opens a window and asks for "Login as", to which I enter root. Then immediately I get a messagebox that says "Disconnected. No supported authentication methods available (server sent: publickey, keyboard-interactive).

U9-H is on and I am in the CoreElec configuration program.

I have looked through the long list of putty options, but am completely lost as to what the problem is and have no idea how to proceed.

Can anyone help?

If it matters, windows 10 on my laptop, ethernet cable running to the U9-H. On the U9-H wireless network inactive, wired network active. Under connections wired IP address present. Under services Samba enabled, SSH password disabled, Avahi enabled, Cron enabled, Bluetooth disabled.

Oh, Putty is using port 22 for SSH. Should I be using a different port for the U9-H?

Thanks.
 
Last edited:
#3
Thanks for the info, BUT... I cannot get past entering the Login. I get Login as:. I enter "root" and hit return. Then I always get the error message I stated above. I never get to it asking me for a password.

Any ideas?

Is there an alternative way to flash CoreElec to the U9-H?
 

Skynet

Administrator
#4
Be sure your firewall does not block port 22.
Try to disabled it for a test.
Can you ping the U9 from your PC ?
 
Last edited:
#8
Ok, ping worked fine. 11/12/11ms was the result, no packets lost.
Then I tried to Logon with Putty and got the same error message as above after entering "root".
Pinged again, this time 4/4/4ms and no packets lost.

So communications and the connection would appear to be ok, which begs the question, why am I getting this error message and what can I do to resolve it?

If it matters, my SD card had an OTA update from 8.95.7 to 8.99.2.
 
#9
Yahoo!!! Success!!! (y)(y)(y)

Ok, I think I found the problem (quite by accident, of course).

Under CoreElec Configuration, under Services/SSH, I had "Disable SSH Password" enabled.
By DISabling this setting, the error message I was getting above disappeared and I was asked to enter a Password.
I entered "coreelec" and I was in.

SO thank you everybody who tried to help. Now to see if I can get my A2 Lite remote working as I would like. :rolleyes:
 
Top