MINIX NEO C, USB-C Multiport Adapter - Gigabit Ethernet Driver

#4
Same problem for me. I'm not able to have this adapter working on my MB pro 2018 on Mac os 10.4.1 with last driver installed.
I tried to see if the software extension was loaded but it was not loaded until I didn’t run the command:
Code:
sudo kextload /Library/Extensions/AX88179_178A.kext
Then, it is loaded but still the interface does not appear on my network settings.
Now, if I run
Code:
kextstat | grep asix
I get
Code:
175    0 0xffffff7f846a5000 0x9000     0x9000     com.asix.driver.ax88179-178a (1.12.0) 5062930F-B7EB-3AA9-8DA5-4E197D09CD07 <54 23 6 5 3 1>
But yet, I do not see the interface in my networking list.

Could you please help me to resolve this annoying issue.
 
#5
Same problem for me. I'm not able to have this adapter working on my MB pro 2018 on Mac os 10.4.1 with last driver installed.
I tried to see if the software extension was loaded but it was not loaded until I didn’t run the command:
Code:
sudo kextload /Library/Extensions/AX88179_178A.kext
Then, it is loaded but still the interface does not appear on my network settings.
Now, if I run
Code:
kextstat | grep asix
I get
Code:
175    0 0xffffff7f846a5000 0x9000     0x9000     com.asix.driver.ax88179-178a (1.12.0) 5062930F-B7EB-3AA9-8DA5-4E197D09CD07 <54 23 6 5 3 1>
But yet, I do not see the interface in my networking list.

Could you please help me to resolve this annoying issue.
Have you installed the latest driver version from ASIX website?
https://www.asix.com.tw/download.php?sub=driverdetail&PItemID=131
 
#6
I’ve tried the latest adapter John, but the behaviour is the same. Note that the Kensington adapter I have is working fine on Ethernet, so this is specific to your device.
Version now installed 2.14.0
 
#7
I recently upgrade my MB Pro to Catalina and I'm start expecting issue with the display. when I plug-in the external monitor works for a few secs after flash 1 time, and next time connection is lose.
Any idea?

Best,
Alejandro.
 
#11
Hi John, I tried installing the latest drivers for Ethernet for my Neo C USB C Multiport adapter on my new MBP 16 machine with OSX Catalina 10.15.2. Initially I needed to authorize some scripts got it to run through however the Ethernet is unstable continually drops with latest drivers from the site for OS X 10.15. Any advice? Kextload gives me com.asix.driver.ax88179-178a (1.12.0) 5062930F-B7EB-3AA9-8DA5-4E197D09CD07 and adapter is seen
 
Last edited:

ArcticWolf

Trusted Helper
#12
Hi John, I tried installing the latest drivers for Ethernet for my Neo C USB C Multiport adapter on my new MBP 16 machine with Catalina. Initially I needed to authorize some scripts got it to run through however the Ethernet is unstable continually drops with latest drivers. Any advice? Kextload gives me com.asix.driver.ax88179-178a (1.12.0) 5062930F-B7EB-3AA9-8DA5-4E197D09CD07 and adapter is seen
^^^^^ FAO @MINIX - John :)
 
#13
Hi John, I tried installing the latest drivers for Ethernet for my Neo C USB C Multiport adapter on my new MBP 16 machine with OSX Catalina 10.15.2. Initially I needed to authorize some scripts got it to run through however the Ethernet is unstable continually drops with latest drivers from the site for OS X 10.15. Any advice? Kextload gives me com.asix.driver.ax88179-178a (1.12.0) 5062930F-B7EB-3AA9-8DA5-4E197D09CD07 and adapter is seen
Please send me a PM, I'll then help to resolve this matter.
 
#14
Hi,
Could I get some help please?
I also have this adaptor and MacBook Pro 15 inch, OS version 10.14.6. I can not seem to make the Cable internet connection work. It simply does not see it is plugged in. Went to https://www.asix.com.tw/download.php?sub=driverdetail&PItemID=131and installed the driver Apple Mac OS X 10.9 to 10.14 Drivers Installer V2.14.0 and rebooted. No luck. :(
Went to the next driver available Apple Mac OS X 10.15 above Drivers Installer v2.16.0 but while installing it I get to a section called Installation Type where the Install button is greyed out. It is skipping the Destination Select, as it is jumping from Read Me to Installation type. Any Ideas what is the issue ?

Also please note that the adaptor works well on an Asus laptop to which i just plugged it in and the connection was there. :(
 

Attachments

#17
Hi John. I have the NEO C Multiport Adapter and MacBook Pro, with brand new OS version Catalina 10.15.5. I cannot make the cable internet connection work. It simply does not see it is plugged in. Went to https://www.asix.com.tw/download.php?sub=driverdetail&PItemID=131 and installed the driver Apple Mac OS X 10.15 above driver installer v2.16.0. 2020-01-30. The installation process went well to the end, says “The installation was successful”. But it is not seen in the network list. Please see the attached screenshots.
Also the external monitor via HDMI cable works only for a few seconds then loses connection.
My be the driver needs an update because of new Catalina version?
Thanx for help.
Regards
 

Attachments

ArcticWolf

Trusted Helper
#18
Hi John. I have the NEO C Multiport Adapter and MacBook Pro, with brand new OS version Catalina 10.15.5. I cannot make the cable internet connection work. It simply does not see it is plugged in. Went to https://www.asix.com.tw/download.php?sub=driverdetail&PItemID=131 and installed the driver Apple Mac OS X 10.15 above driver installer v2.16.0. 2020-01-30. The installation process went well to the end, says “The installation was successful”. But it is not seen in the network list. Please see the attached screenshots.
Also the external monitor via HDMI cable works only for a few seconds then loses connection.
My be the driver needs an update because of new Catalina version?
Thanx for help.
Regards
^^^^^ FAO @MINIX - John
 
#19
Hi John. I have the NEO C Multiport Adapter and MacBook Pro, with brand new OS version Catalina 10.15.5. I cannot make the cable internet connection work. It simply does not see it is plugged in. Went to https://www.asix.com.tw/download.php?sub=driverdetail&PItemID=131 and installed the driver Apple Mac OS X 10.15 above driver installer v2.16.0. 2020-01-30. The installation process went well to the end, says “The installation was successful”. But it is not seen in the network list. Please see the attached screenshots.
Also the external monitor via HDMI cable works only for a few seconds then loses connection.
My be the driver needs an update because of new Catalina version?
Thanx for help.
Regards
Please send me a private message, thanks.
 
#20
I also have this Type-C Multi Port Adapter, and cannot get the cable internet connection to work either. I'm running a 2018 MacBook Pro with OS 10.13.6. I enabled the extensions, but for the AX88179_178A, on the System Information page it is not showing as 'loaded':
AX88179_178A:



Version: 1.12.0

Last Modified: 1/6/19, 7:26 PM

Bundle ID: com.asix.driver.ax88179-178a

Loaded: No

Get Info String: ASIX AX88179/178A USB3.0/2.0 Gigabit Ethernet driver

Obtained from: Identified Developer

Kind: Intel

Architectures: x86_64

64-Bit (Intel): Yes

Location: /Library/Extensions/AX88179_178A.kext

Kext Version: 1.12.0

Loadable: Yes

Dependencies: Satisfied

Signed by: Developer ID Application: ASIX ELECTRONICS CORPORATION (5RHFAZ9D4P), Developer ID Certification Authority, Apple Root CA


Help?
 
Top