MINIX NEO C, USB-C Multiport Adapter - Gigabit Ethernet Driver

#4
Same problem for me. I'm not able to have this adapter working on my MB pro 2018 on Mac os 10.4.1 with last driver installed.
I tried to see if the software extension was loaded but it was not loaded until I didn’t run the command:
Code:
sudo kextload /Library/Extensions/AX88179_178A.kext
Then, it is loaded but still the interface does not appear on my network settings.
Now, if I run
Code:
kextstat | grep asix
I get
Code:
175    0 0xffffff7f846a5000 0x9000     0x9000     com.asix.driver.ax88179-178a (1.12.0) 5062930F-B7EB-3AA9-8DA5-4E197D09CD07 <54 23 6 5 3 1>
But yet, I do not see the interface in my networking list.

Could you please help me to resolve this annoying issue.
 
#5
Same problem for me. I'm not able to have this adapter working on my MB pro 2018 on Mac os 10.4.1 with last driver installed.
I tried to see if the software extension was loaded but it was not loaded until I didn’t run the command:
Code:
sudo kextload /Library/Extensions/AX88179_178A.kext
Then, it is loaded but still the interface does not appear on my network settings.
Now, if I run
Code:
kextstat | grep asix
I get
Code:
175    0 0xffffff7f846a5000 0x9000     0x9000     com.asix.driver.ax88179-178a (1.12.0) 5062930F-B7EB-3AA9-8DA5-4E197D09CD07 <54 23 6 5 3 1>
But yet, I do not see the interface in my networking list.

Could you please help me to resolve this annoying issue.
Have you installed the latest driver version from ASIX website?
https://www.asix.com.tw/download.php?sub=driverdetail&PItemID=131
 
#6
I’ve tried the latest adapter John, but the behaviour is the same. Note that the Kensington adapter I have is working fine on Ethernet, so this is specific to your device.
Version now installed 2.14.0
 
#7
I recently upgrade my MB Pro to Catalina and I'm start expecting issue with the display. when I plug-in the external monitor works for a few secs after flash 1 time, and next time connection is lose.
Any idea?

Best,
Alejandro.
 
#11
Hi John, I tried installing the latest drivers for Ethernet for my Neo C USB C Multiport adapter on my new MBP 16 machine with OSX Catalina 10.15.2. Initially I needed to authorize some scripts got it to run through however the Ethernet is unstable continually drops with latest drivers from the site for OS X 10.15. Any advice? Kextload gives me com.asix.driver.ax88179-178a (1.12.0) 5062930F-B7EB-3AA9-8DA5-4E197D09CD07 and adapter is seen
 
Last edited:

ArcticWolf

Trusted Helper
#12
Hi John, I tried installing the latest drivers for Ethernet for my Neo C USB C Multiport adapter on my new MBP 16 machine with Catalina. Initially I needed to authorize some scripts got it to run through however the Ethernet is unstable continually drops with latest drivers. Any advice? Kextload gives me com.asix.driver.ax88179-178a (1.12.0) 5062930F-B7EB-3AA9-8DA5-4E197D09CD07 and adapter is seen
^^^^^ FAO @MINIX - John :)
 
#13
Hi John, I tried installing the latest drivers for Ethernet for my Neo C USB C Multiport adapter on my new MBP 16 machine with OSX Catalina 10.15.2. Initially I needed to authorize some scripts got it to run through however the Ethernet is unstable continually drops with latest drivers from the site for OS X 10.15. Any advice? Kextload gives me com.asix.driver.ax88179-178a (1.12.0) 5062930F-B7EB-3AA9-8DA5-4E197D09CD07 and adapter is seen
Please send me a PM, I'll then help to resolve this matter.
 
Top