NEO X8-H Plus: Android Lollipop OS Firmware [20170612]

if you read the whole thread there is plenty of advice;)
I have read all posts, include #167
How you can detected so easily? I have tried a lot and no luck.
That video once opened the burning tools, he already have detected device id (HUB1-4) but mine is totally empty/blank...
 
Last edited:
Exactly the same problem with both of my boxes the USB download is not showing in the devise ID

Even after i follow the proceedures in the video. By inserting the pin pushing the on button and connecting the power supply
 

pusb87

Trusted Helper
@claudchan , @Ray333

it can be problematic and you may have to try different usb ports and cables and even a different laptop/PC. It does work with Win 7 or 10 but some say win 7 is better. I use win 10. USB 2 is reportedly better

but just in case the power adapter needs to be unplugged first, then plug in the power adapter and then press and hold in the reset button and then hold the power button down at the same time for a good few secons, once a connectio is made you release both buttons.


Sometimes as i said its a pig to get a connection and just as you are about to give up you get one.

Once you do remember which port and cable you used for next time !!
 
Last edited:
Can you suggest a good tool which works to burn the Firmware? I've tried a few, but haven't been able to make them work for the situation, i.e. burning the .img file to the SD card, such that either the boot reads from it directly, or in Recovery mode, I can Upgrade from EXT and read from the SD card.
 
Finallu updated my NEO X8-H plus to 5.1.1

https://mega.nz/#!UZV1UbyD!50Lw8HPXoewuTTJI1b9jA20-IzegCwHJqsISLcQJsJc -- Amlogic USB burning tool . For now this is the compatible version.

Software to download-- IMAGE FOR LOLIPOP.
https://mega.nz/#!n2hDWYRQ!lAYRyRRKJ1gzhBM59iyTOnSgh4rs3glm5jcnJFPA1w4

Follow the instructons in the video.
Install usbburning tool
Select the image that you downloaded.
Dont close this window.



1. Connect usb to LAPTOP
other end OTG to MINIX
POWERON with pusing the reset needle for 2 mints. If the device is detected the HUB name appears in the USBburning tool. Then click on start.

If no check for any other USB connected to ur laptop.
remove all usb connections.
Poweon MINIX
Insert the OTG again, this should work as it worked for me.

Once installed .. Minix takes some time to comeup. wait patiently
I am from India, so adjust your time and also dispaly settings.
some issue with Netflix and it is not working
hope we may see some other issues with app as some of the apps are not compatible.
Good Luck guys.
 
I have tried various combinations of the Burning Tool and IMG files mentioned in the first post of this thread and in the post above (by 'svvp'), and I cannot update my device.

Computer is Windows 10; no problems connecting to the Minix.

Suggestions appreciated.


Screenshot 2019-06-08 21.17.45.png.jpg


The errors noted are seen in these screenshots, below.
The 'xml' error occurs when I try to import the IMG file.
The USB Transfer Error occurs during the actual update.

Screenshot 2019-06-08 20.42.11.png



Screenshot 2019-06-08 20.57.30.png
 

Attachments

Last edited:
It took me many hours of work to get this working. I'd like to share with you what I found so that I may save some of you the work and the frustration.

1. The usb cable in use must be a good cable. It worked for me only after I used an original samsung cable supplied with galaxy s6 phone. When I used other cables the usb_burning_tool did not recognize my minix device

2. The PC must recognize the minix device as a usb device before the usb_burning_tool is run. Verify that its recognized as a usb device on your PC with the right drivers and only then run the usb_burning_tool

3. After the lollipop was installed I had no sound from HDMI on the device. Only after I installed soundabout (free version from apk) it was solved.

I hope I saved some of you some trouble.
 

notrui2

Trusted Helper
Has anyone else had the problem with Ethernet unable to stay active after upgrading to lollipop? I'm searching for a solution.

Thanks.
Never had any problems with ehternet after upgrade.
However it is better to use static ips, for your router , Minix etc.
With that (static ip) you can awake a device from sleep mode with no problems.
If you have DHCP you may have a problem with awake a device from sleep mode.
 
I've tried to update my minix Neo X8-H without success. I did de procedure for more than four times and the equipment doesn't load ans stops the minix logo. Someone could help me from now with some suggestion? One more information, I restart many time and I waited more than hours to start after the update.
 

Attachments

Last edited:

notrui2

Trusted Helper
I've tried to update my minix Neo X8-H without success. I did de procedure for more than four times and the equipment doesn't load ans stops the minix logo. Someone could help me from now with some suggestion? One more information, I restart many time and I waited more than hours to start after the update.
Your device is a x8h and not x8h plus (different devices).
Download the correct firmware for the device and flash again.

Choose a custom firmware if you want (custom lollipop) or official firmware:

https://theminixforum.com/index.php...-5-1-1-flashed-with-probox2-ex-firmware.1502/
 
Never had any problems with ehternet after upgrade.
However it is better to use static ips, for your router , Minix etc.
With that (static ip) you can awake a device from sleep mode with no problems.
If you have DHCP you may have a problem with awake a device from sleep mode.
Thanks for the response. I've tried both Static and DHCP. My wired ethernet will start and I can ping it but once I start a video in youtube or plex, the ethernet stops responding to pings. My guess is there's a buffering issue (possibly hardware problem). This only happeded after upgrading to Android 5.1.1
The problem also occurs if I try to do an update to apps from playstore while using wired.
Response time with WIFI is 3 times slower than wired so I prefer wired.
Not likely to buy another box like this given the support issues.

AND MY LAST OBSERVATION...IS THIS SIGHT MINING ...because my CPU Ute is HIGH WHEN HERE.
 
Last edited:
Top