NEO X8-H Plus - Doesn't support new versions of Apps

#1
Hi all,
I cannot upgrade Apps on my NEO X8-H Plus, message is "your device is not supported".
How can I upgrade my device? Do I have to upgrade Android? In case wich version is supported and How can I do that?
My FW version is old, but the tool says device is updated.

Thank you all in advance.
 
#3
Thank you very much notrui.
I checked on device:
- Minix OTA says KOT49H.20170119 and that system is updated (!?)
- Android is 4.4.2
- Kernel is 3.10.33
Can you confirm that X8H_PLUS_LOLLIPOP_RC2.rar is what I need to install? It will update both, android and FW, correct?
I can't understand why OTA does not get any update :unsure:
 

notrui

Trusted Helper
#4
Thank you very much notrui.
I checked on device:
- Minix OTA says KOT49H.20170119 and that system is updated (!?)
- Android is 4.4.2
- Kernel is 3.10.33
Can you confirm that X8H_PLUS_LOLLIPOP_RC2.rar is what I need to install? It will update both, android and FW, correct?
I can't understand why OTA does not get any update :unsure:
OTA does not work to update from kitkat (4.4.2) to lollipop (in this particular device)

You need to flash via usb burning tool (manual).

At least you will get a more recent firmware but: (if you decide to update)
-x8 h plus is an old device
-lollipop is also old but is more recent than kitkat
-i also have to say that some apps may no longer with lollipop OS.
 
Last edited:

Marty

Moderator
#8
No device ID appears.
I'm using Win11.
This is so hit and miss, members have reported so differently on how they connected, try holding power and reset pin for longer, try releasing the power after power on but keep the reset pin in, basically keep trying various options and let us know what you have tried.
Can you confirm you are using the USB cable that came with the unit.
 
#10
1641043238566.png
- Device is quite full, can it be the cause?
- Different tool version, can it be a path to follow?
- I tried longer time and various sequences of button release without success

:cry:
 
Last edited:

notrui

Trusted Helper
#11
No device ID appears.
I'm using Win11.
I used windows 7 to flash the device.

Can you try with another OS? Or another PC?

Check your windows 11 installation:
-check installed programs
-disable internet connection (when update)
Etc...

Note:
Check link post #2 ( Use usb burning tool that is provided by MINIX)
 
Last edited:
#12
I tried on a Win 7 PC, not connected to internet.
Installed USB tool v2.0.6.2 (the older one, just to try something different), successful drive installation, no errors.
When I plug in the NEO there's a sound from PC and it appears on computer resources
Then I open the tool but it doesn't list any device
Again, the yellow frame for devices on the tool is empty :(
Do I have to abandon the fight?
 
#13
When I plug in the NEO there's a sound from PC and it appears on computer resources
If you are hearing this and the unit shows as a resource then you are not entering flash mode. So, there are many reported ways of connecting as I said above, have you tried holding the reset button and power button together then plugging in the power? Its a bit tricky but this method has helped me before. In a nutshell, you need to get the unit into flash mode, if you are seeing it as a resource then try again.
 
#16
If you are hearing this and the unit shows as a resource then you are not entering flash mode. So, there are many reported ways of connecting as I said above, have you tried holding the reset button and power button together then plugging in the power? Its a bit tricky but this method has helped me before. In a nutshell, you need to get the unit into flash mode, if you are seeing it as a resource then try again.
Plugging power while holding both reset and power buttons caused a sound , nothing on computer resources (that looked good), but still nothing on burning tool, and this is something strange because I saw on the video that appears always HUB1-4 device Id on the tool, and when pushes buttons just changes the status :unsure:

1641381452368.png
 

Villa

Administrator
#17
When I plug in the NEO there's a sound from PC and it appears on computer resources
That would indicate you have the device powered up!

You need to have the device powered off before connecting to the PC. Then you insert a paperclip into the Recovery hole, press and hold, then press and hold the power button until you hear a connection sound.
 

MINIX Official Website
MINIX on Facebook
MINIX on YouTube
MINIX's Telegram Channel
MINIX's Telegram Group

Top