NEO X8-H Plus Lollipop firmware update with Burn Card Maker

pusb87

Trusted Helper
#61
Finless MINIX X8-H Plus Android 5.1.1 (Lollipop) ROM 1.0 works with rj45 wired ethernet has some limitations and it didn't suit me either
As the finless ROM is based off the Minix Lollipop ROM then i suspect any limitations ( what are they ?) will be the same as the Minix ROM.

How does it not "suit you " ?
 
#62
I have tried for hours now to get it working. The Minix just does not want to start loading.
THe only thing i see is ending up in the BOOT menu, and then i can't recover from SD.

What can i do better? Nothing seems to work.
 
#63
Hey guys, is there another trusted link for the burncard zip? The post link here is not working, and Im not sure where else to go on the web where I can trust a download.

Thx in advance
 

Villa

Administrator
#65
#67
Hi. i m new here. But i have managed to upgrade my neo x8h plus to later lollipop. i use the burn card maker. i hope i can help.
1) download the Burn Card Maker into you pc
2) run the burn card maker in your pc
3) insert an SD card into your pc
4) format the SD card
5) download the X8H_PLUS_LoLLIPOP_RC2.rar file (you need to un-rar the file to get 3 files inside where one of it is the .img file)
5a) do not change the file name from .RAR to .IMG,you have to un-rar the file (just like you would un-zip a zip file)
6) copy the .img file into the SD card via the burn card maker
7) remove the SD card from your pc and insert it into your minix (minix power is off)
8) insert a pin to press and hold the recovery button and at the same time turn on the power to minix (just like how you would start your minix)
9) you should be able to see the screen showing upgrading
10) wait and hopefully it will upgrade properly
Mine i did it this way and it was upgraded straight through.

Hi if i update from kikat to lollipop using the burn card maker thing. Will it erase everything on the minix. I mean previous apps and everything on the box before. let me know. Thanks
 
#69
Hi there. I'm kinda stuck (and annoyed by now after 2 hours of trying).

First tried to upgrade my X8-H Plus via the USB Burning tool. First ver.2.0.9, then 2.1.7.1. In both cases my Minix did not show up, while pressing the recovery button and power button. Tried 2 differend USB cables. Not working. Booted my laptop does see the Minix over the USB cable. Will try one other cable from work tomorrow, which I use to download results from testing equipment.

So I thought, lets try the Burn Card Maker method with SD following the steps. Creating the card with the image, no problem. Also checked the download. All seems good. After figuring out the correct way to insert the SD in the Minix (checked File manager to be sure it detected the SD card, and showed the content), I shut down the Minix. Unplugged everything but the power and hdmi cord, and have the SD card (still) in the slot.

Fired the Minix up while pressing the Restore button and power button (not releasing and waiting till update screen) brought me to the selection screen to restart, check Ext. card (SD), and there is was not showed.

Any suggestions?

Content of the SD card:
<DIR> System Volume Information (I guess from the formatting process)
<FILE>aml_sdc_burn.ini (644B)
<FILE>bootloader.PARTITION (385.14KB)
<FILE>X8-H_Plus-Android_5.1-20170612-Burning_Tool.img (894.52MB)

Sizes are as shown on my Minix FileBrowser.

When you want/need pics, just ask and I'll upload those tomorrow.

Thanks in advance.
 
#70
Guys please help, I'm.also Stuck after 2 hours, done everything correctly. Followed the steps, burnt the img file on ad card. There are multiple files on the card i checked them. I then insert sd card into an sd card reader and put it into my minix box. I hold the restore button and press power button once. I sometimes get the selection screen to restart or sometimes it just loads like normal. I never get the upgrade screen, please help I'm so frustrated
 
#71
Guys please help, I'm.also Stuck after 2 hours, done everything correctly. Followed the steps, burnt the img file on ad card. There are multiple files on the card i checked them
  1. You need to format the card from the burn card maker tool, it'll pop open the windows tool with specific options for the SD card.
  2. The burn card maker will stop responding after 100%. You have to wait for it until the "success" alert opens up.
  3. Unplug the power cord. Pop in the SD card. Plug the power cord back in. Push the restore pin and hold it in. Press the power button once. Wait until the progress bar appears, then you can release the restore pin.
  4. Learn from my mistake, just leave it alone until you can pick which launcher to use.
<FILE>aml_sdc_burn.ini (644B)
Open this file, and look at the content. If it's not the right `.img` file, you have to wait for the success alert (step 2 above). Personally I use the RC2 image from the official thread.
 
#72
Hello,
I'm hoping someone may be able to assist.

At first, I tried to upgrade my X8-H Plus via the USB Burning tool.
The Minix did not appear (I tried three different USB ports and two USB cables).

Afterwards, I tried the Burn Card Maker/SD method.
This appeared successful - I received the "upgrade" message.
I navigated to the device's "about" - can confirm it is running version 5.1.1

I can connect and search the internet, I can view files on a USB etc.
However, when I tried to download Netflix app using the play store, I received a message that the device is not compatible* (I cannot download the app).
I followed the instructions on this website: https://help.netflix.com/en/node/57688
After I installed the app, it opened, but every 10 or so seconds the screen would turn completely black.
Even after exiting the app, the screen was flashing black.
I uninstalled the app, and the black flashing stopped.

** Also, I receive the same message (device is not compatible) trying to download Disney Plus app. It's frustrating that i've just paid for a years subscription and haven't even been able to use it.

I'm not sure if I have done something wrong with my initial install (x2) or there are settings I can change so that my device is "compatible", or something else. Can anyone guide me in the right direction?

Any help would be greatly appreciated.

THANKYOU.
 
#73

Villa

Administrator
#75
I did the whole process and after all, my screen is frozen like this. So how to fix it?

View attachment 2521
This thread is for the X8-H Plus. Elsewhere you say you have the X8 Plus!
https://theminixforum.com/index.php?threads/newby-x8update.3154/post-26493
https://theminixforum.com/index.php?threads/neo-x8-x8-h-x8-plus-009fw-20160328.46/post-26494

If you have flashed a X8- H Plus firmware to your X8 Plus you are going to have issues! ;)

You need to flash the correct firmware for your device.(y)
 
#77
Hi guys
I am trying to update the FW on my minix( x8-H plus) box.
I’ve got all 3 files correctly on a previously formatted sd card using the BCM.

I shut down the minix box, unplug the power cable then I insert the sd card and put the power cable back in.
Then I hold down the recovery button and press the power button once.
Every time I do this I get the recovery screen.

I have tried with different sd cards and checked the 3 files on them.
The disc image file is 915.994KB

Any help would be greatly appreciated as I don’t know what else to do.
BD661AE6-9F15-4386-9A6C-2ACFF7F3F4BE.jpeg
 
#78
Happy Xmas!
Hi, I did a factory reset from Android I was unable to boot the box again.
I tried to reflash it using OTG and SD Card and I was unable to finish the step.
Errors with otg while flashing and same with SDCARD
Any idea? thx!
 

MINIX Official Website
MINIX on Facebook
MINIX on YouTube
MINIX's Telegram Channel
MINIX's Telegram Group

Top