Netflix 5.3.1 installation problem on U9-H

#1
Hi, just came across an issue with Netflix over the last few days and don’t know if it’s possible to fix or not.
I had version 5.3.1 installed on the U9-H and it’s been working fine up to a few days ago, it wouldn‘t play anything and I logged out of the app to see if it would fix it.
Now I can’t log back in, it’s giving me the “wrong credentials” error even though they are correct.

I’ve gone through the other threads on here already about this happening to others and can’t find a solution. The only thing I’ve seen mentioned was to try other versions of the app, a version 4.xx and version 6.20 and 6.26 I think. I’ve tried them and no joy, one of the version 6 worked but the picture quality was terrible.

Is there anyway to get 5.3.1 back working again?

Thanks
 
#2
Hi, just came across an issue with Netflix over the last few days and don’t know if it’s possible to fix or not.
I had version 5.3.1 installed on the U9-H and it’s been working fine up to a few days ago, it wouldn‘t play anything and I logged out of the app to see if it would fix it.
Now I can’t log back in, it’s giving me the “wrong credentials” error even though they are correct.

I’ve gone through the other threads on here already about this happening to others and can’t find a solution. The only thing I’ve seen mentioned was to try other versions of the app, a version 4.xx and version 6.20 and 6.26 I think. I’ve tried them and no joy, one of the version 6 worked but the picture quality was terrible.

Is there anyway to get 5.3.1 back working again?

Thanks
Unfortunately 5.3.1 is no longer working:(

Have a look here!
https://theminixforum.com/index.php?threads/problems-with-netflix.2290/#post-16149
 
#3
Ok, thanks for your help. Do you have any idea if this is going to be a problem with the new U22 boxes coming out soon, or have the minix team been able to fix it?
I’ve just tried to install the recommended Netflix v 6.26 on my U9 and it’s working like before but the picture quality is crap as usual.

I was planning on upgrading to the U22 anyway in a few weeks, but not now if Netflix isn’t going to work properly on it. 5.3.1 was ideal on my older X8 and U9 boxes, and it’s a shame it’s gone now.
 
#4
Ok, thanks for your help. Do you have any idea if this is going to be a problem with the new U22 boxes coming out soon, or have the minix team been able to fix it?
I’ve just tried to install the recommended Netflix v 6.26 on my U9 and it’s working like before but the picture quality is crap as usual.

I was planning on upgrading to the U22 anyway in a few weeks, but not now if Netflix isn’t going to work properly on it. 5.3.1 was ideal on my older X8 and U9 boxes, and it’s a shame it’s gone now.
We as a family use Netflix pretty much daily and find the quality decent on the U9... now I know, my decent may not be your decent. In saying that, we have two older TV's, LCD and a Plasma so I don't get to excited about the quality....both around 10 yrs old:(

I was also given a Netflix certified device and on the same TV's I actually don't notice a whole lot better quality.. TBH.
Some of the features that you get with a certified device do obviously work as they should.

To answer your question....MINIX devices are not Netflix certified so we are going to be juggling versions to find one that works the best.... At least temporarily!

I'd also like to add, Netflix is the one to blame for this issue, not MINIX !

https://theminixforum.com/index.php?threads/u9-netflix.151/#post-630
 
#5
There’s a night and day difference for us on our tv now since installing Netflix 6.26 over the old 5.3.1 version. The old version wasn’t amazing quality, I’m not sure of the exact resolution it streamed, but it was fine. Now with the current version 6, it looks like a low res YouTube video and you can really tell the difference.
 
#6
There’s a night and day difference for us on our tv now since installing Netflix 6.26 over the old 5.3.1 version. The old version wasn’t amazing quality, I’m not sure of the exact resolution it streamed, but it was fine. Now with the current version 6, it looks like a low res YouTube video and you can really tell the difference.
Sorry to hear that:(

I honestly don't find it that bad!

If you're a Kodi user you could consider trying that, the quality should be better!
https://forum.kodi.tv/showthread.php?tid=329767
 
#7
Tried that earlier, got it installed and looks like it’s setup but when I click on any movie or show to play it nothing happens. I can get into my Netflix account and browse everything, but nothing will play.

Not sure if it’s something to do with it looking for the correct Netflix ESN key of the minix box. I can’t seem to find out where to get this info from on my box anyway.
 
#8
Tried that earlier, got it installed and looks like it’s setup but when I click on any movie or show to play it nothing happens. I can get into my Netflix account and browse everything, but nothing will play.

Not sure if it’s something to do with it looking for the correct Netflix ESN key of the minix box. I can’t seem to find out where to get this info from on my box anyway.
I really don't use the Kodi version very often. I'm not currently near my box but I'll check later and see if it's working for me.
 
#9
I really don't use the Kodi version very often. I'm not currently near my box but I'll check later and see if it's working for me.
Finally got netflix workimg with kodi, content is playing now. Just having an issue with the video quality, it seems to be pretty low quality too. I’m not sure if there’s some settings need to be tweaked in kodi or what.
 
Top