Netflix 5.3.1 Not Working

#1
I’ve got a U9H and 2 U-1 boxes and they work great for Kodi and some sports apps I have. However I haven’t used Znetflix for a while and am not able to use it on any of my 3 devices. I’m using Netflix 5.3.1 APK and am not able to log in. It keeps saying the credentials are invalid. I know they work as I am able to log out and in on my iPad without issue.

Is there anything I can do to get Netflix working? I’ve rebooted the boxes. I’ve reinstalled 5.3.1 on one of the boxes and it didn’t make any difference.
 
#2
. I’m using Netflix 5.3.1 APK and am not able to log in. It keeps saying the credentials are invalid
Interesting that you are having that problem, I experienced this same issue last night when I tried to log in on a U1. I didn't have enough time to try and resolve the issue, I may have time tonight.
I have 5.3.1 installed and working on 2 U9's so it does work.
 
#4
@Cbsmith ,@ePuL ...do you both by chance get a message or have Google Smart Lock feature turned on ?
I noticed this message pop-up at the bottom of the screen just before I entered my log-in credentials.... this might be causing some or all the problems for some reason ?:unsure:

Sill trying to sort it out!...... I have a feeling it's more to do with the fact that MINIX are not Google / Netflix certified ?:mad:

One thing I can ensure you, it has nothing to to do with your log-in credentials.... I reset mine twice !:(
 
Last edited:
#5
I have been using Netflix 5.3.1 successfully on a Minix Neo U1 for the past 7 months. Two days ago, Netflix gave me a message that my userid and password were not valid. The same userid and password allow me to log into Netflix on my tablet and desktop. I tried everything (uninstalling/reinstalling, clearing data, etc...) - no luck on the U1. Have you had any luck solving this problem?
 
#8
Alas, that is what I had to do. I uninstalled 5.3.1 and installed v 4.16. I logged in immediately without any error messages. I hope that you can find some way for us to work with 5.3.1 - it is a better version.
 
#16
On my 2 U-1 units I can run a Netflix version 6.24 and log in without an issue and play content. It evens looks to be 720p content. I got this version by googling Netflix Android APK and it was in the first couple links.

On my U-9H I am forced to run an older version of Netflix, which is disappointing. I had to get version 4.x from googling Netflix Android APK again but this time choosing the Netflix link and it let me download an older 4.x version. It works but does not appear to be a HD version. It is too bad I have not been able to get 5.3.1 working or anything newer than it.
 
#19
I'm noticing with this netflix workaround (sideloading the old version) that now, when it starts up, you get a full blackscreen with the error about the billboard not loading. You can scroll down to choose but I wonder if this is as good as it'll get on the u9-h? I suspect it's going to get worse :(
 
#20
I'm noticing with this netflix workaround (sideloading the old version) that now, when it starts up, you get a full blackscreen with the error about the billboard not loading. You can scroll down to choose but I wonder if this is as good as it'll get on the u9-h? I suspect it's going to get worse :(
What version are you using ?
 
Top