RosaLinux on Z83-4 (Pro)

#1
I tried to installed RosaLinux on a Z84-4 (bought Pro-Version with pre-installed Win10). After some frustrating attempts it works fine ... BUT there was a big pitfall! To avoid this frustrating for others I will share here my experience:
Tried to install RosaLinux R8, R8.1 with KDE4, either the 32 and 64 bit version (UEFI-versions): no chance! 32-bit does not boot from USB, 64 bit installers died with strange message after large, large timeout.
What works is RosaLinux R11 64-bit UEFI KDE (http://mirror.rosalab.ru/rosa/rosa2016.1/iso/ROSA.Fresh.R11/ROSA.FRESH.KDE4.R11.x86_64.uefi.iso)
It boots from USB, installs without any trouble, and WLAN is getting started with the patch given in this thread:
https://theminixforum.com/index.php?threads/linuxmint-19-and-do-not-detect-wifi-network-card.376/
1 - sudo cp 4345r6nvram.txt /lib/firmware/brcm/brcmfmac43455-sdio.txt
2 - reboot

(simply copy and rename a txt-file of windows-installer package)
Instantly Rosa detects WLAN, establishes Internet connection... and shows a lot of updates ! So I clicked on [update]... FATAL! :oops: and during update WLAN died... and after reboot I got a black screen, HDMI-TV said "no signal" and my beautiful RosaLinux installation was dead :eek:
Booting again and selecting previous Kernel version (after update it was actual 4.15-desktop-60...), previous 4-15-desktop-45... and it worked again :)
In KDE Boot Settings I selected this previous Kernel as the default and now I'm happy with my Z83-4-ROSALINUX R11 installation, booting is very quick, WLAN works fine and I can watch Netflix on my HD-TV (And I can only pray, that nobody of my family will click again on [update]... )
 

notrui2

Trusted Helper
#2
Hi. Thank you for your feedback.
I tried a few days ago RosaLinux R11 on VMware and i liked very much.
It is very user friendly ☺.
It is very easy to work, and updates works very well.
 
Top