U9-H Display problem

#1
My Minix U9-H has been working fabulously...until now. I have not used it in a couple days but today when I fired it up the display background is Bright Red and the thumbnails are hazed. White screens are a lime green. I tried all the resolution setting. I changed the HDMI cable. Connected it to a different input on my Home Theater and finally Factory Reset the Box but nothing has helped. I believe this may have happened years ago but I don't remember how it was resolved.
Any suggestions are welcome.
 

gdf

Active member
#2
I have seen this several times on my U9, the issue was resolved by restarting and on one U9 a change of the HDMI lead solved the recuring problem, however this may have only needed a re-seating of the HDMI cable in either the TV or U9, so perhaps try that first.
 
#3
gdf, Thanks for your reply. I tried numerous restarts, cold boots and unplugs but nothing worked. But today the power in the area went out and when it came back on, It fixed the problem...go figure.
 

notrui

Trusted Helper
#4
My Minix U9-H has been working fabulously...until now. I have not used it in a couple days but today when I fired it up the display background is Bright Red and the thumbnails are hazed. White screens are a lime green. I tried all the resolution setting. I changed the HDMI cable. Connected it to a different input on my Home Theater and finally Factory Reset the Box but nothing has helped. I believe this may have happened years ago but I don't remember how it was resolved.
Any suggestions are welcome.
This is the latest firmware:

https://theminixforum.com/index.php...91120-community-edition-nougat-firmware.2107/

Notes:
-Android 6 should work fine but in case you want to try that above (i don't know what firmware you have installed).
-i only use tv speakers...
 
Last edited:

MINIX Official Website
MINIX on Facebook
MINIX on YouTube
MINIX's Telegram Channel
MINIX's Telegram Group

Top