Anyone still using Minix NGC-1?

#1
I bought my Minix NGC-1 in Feb 2017, and I'm really impressed with how stable its been for last 2 years - rock solid stability, I'm really quite impressed and was surprised they discontinued this model, perhaps its replaced with newer model? It's been great for my daily computing needs with fast bootup. I upgraded the RAM to 8GB soon after buying it, which has made it even faster overall. Just wondering if anyone else is still using their NGC-1 as not much in the way of comments on this forum!
 
#5
It's one of my favourite gadgets ever created, it just wouldn't throttle.

1574405942646.png

The only shortcoming is lack of dual-channel memory support.
 
Last edited:

notrui

Trusted Helper
#6
If your CPU is always (or most of the time) in 100% usage , you should have installed some program(s) that is doing that.

Check also your installed programs and processes (order by CPU usage).

Check if you don´t have any virus/malware.
Install for example avast and check.
 
#15
Hi,

Am I in the wrong place or did tons of NGC-1 forum messages get deleted?

I use this daily as well and it is always on. I run MediaPortal client on this device.

Does anybody else ever have their audio go funky every once and a while? It gets stuttery, almost like slow motion but still at the same pitch. Happens when watching video or just playing music. I'm sending audio out via HDMI.

Thanks for any input
 
#16
Hi,

Am I in the wrong place or did tons of NGC-1 forum messages get deleted?

I use this daily as well and it is always on. I run MediaPortal client on this device.

Does anybody else ever have their audio go funky every once and a while? It gets stuttery, almost like slow motion but still at the same pitch. Happens when watching video or just playing music. I'm sending audio out via HDMI.

Thanks for any input
There were more posts about NGC-1 on the old forum, though unfortunately those were lost. We had to start from scratch on the new forum.
I haven't noticed the audio issue myself, what media player application are you using when this occurs?
 
#17
I primarily use MediaPortal, but sometimes stream audio via MS Edge. I know for sure it happens with MediaPortal and I'm pretty sure it has happened with Edge as well. However, once the problem happens, audio is messed up everywhere, not just the program I was using, and I must reboot. I thought in the old forum there was at least one other person that has experienced the same thing as I. I was logging in to check if there have been any more. I suppose I should've started a different thread about this, this time. Sorry.
 
#18
I start using it back today, but my NGC-1 keep booting again and again. Does any one have the latest BIOS firmware for me to install and how can i install it?

I think i have BIOS 103 version now
 
#20
Yes. I use NGC-1 and upgrade it to 8 gb RAM and yestarday upgr. SSD to 512 GB Transcend. I am having trouble backup the image from the old ssd. I have installed new windows, but I cannot understand uefi shell. ... some help from someone?
Overall, I'm very pleased with the machine.
 

Website:http://minix.com.hk
Facebook:  facebook.com/minixtech
Telegram Channel: t.me/minix_channel
Telegram Group:    t.me/minix_group

Top