Network Boot / PXE not working

mak

New member
#1
Hello all

I am trying to use Citrix Provisioning Services (OS Image Streaming over network) to boot the MINIXs from a centrally managed/distributed OS Image. Network Boot/PXE Tests also done with Microsoft MDT/SCCM. But I can't for the life of mine get my MINIXs to boot from network. The PXE settings in the network/DHCP environment are fine since other devices boot over network successfully. So the root cause is probably to be found in the MINIXs.

Same goes with a "proxy/helper" USB Stick that actually starts the EFI Network Boot process. It just does not work. The USB stick gets triggered but the device falls back to EFI Shell immediately.

Updated to BIOS 1.8, set the Boot order correctly... blah blah. all done.

Could it be that the UEFI Network Stack is not being properly loaded in the UEFI environment? To me it seems so, since in EFI Shell the commands ifconfig and ipconfig both return errors ("Locate protocol error - 'Ip4Config Protocol'" and "Locate protocol error - 'Simple network protocol'" respectively)...?

Anybody successfully booted NEO Z83 devices over network?

Thanks in advance
mak
 

notrui2

Trusted Helper
#2
Hi. I never tried (in any device) that but i know how it works.
I dont have your device also but you can try changing order in UEFI (first device network , ethernet)

Use static ip in the devices , update ethernet drivers if you need.

Check firewall , uninstall all possible blocking programs or disable temporarily , anti-virus , etc

20190805_165009.jpg

This picture is from Minix N42C-4 BIOS.
You have two options (to boot in this case a network OS):
-Change order in BIOS-Boot option
-When minix restarts OS if you press one key (i dont remember what key) a menu appear and you can select your boot option
 
Last edited:

mak

New member
#3
Thanks for your input! Unfortunately I tried all your tips alerady before posting here, so no luck :-/

It seems the boot options between N42 and Z83 are a bit different. Your boot options list the exact network card/controller with options to use either IPv4 or IPv6. This is how I also know it from other UEFI devices. With Z83 only "Network" can be chosen. No specific NIC or IP4/6 conf seems available.

Could I ask one of the Minix Dev-Team/Core Team/Support Staff to jump in? I really suspect this has to be some problem in relation to loading the Firmware/UEFI Network Stack at the correct time in Firmware/UEFI environment/runtime...

Two more indicators into this direction that I discovered in the mean time:
1) When probing my Switch via CLI, I cannot see any MAC Address on the connected switchport for as long as there is no "real" OS booted on the Minix (i.e. Windows, Acronis recovery USB Media, et al). The ethernet link is up on 1GbE FDx, but no MAC Address gets registered which to me seems as if the Minix is not communicating over ethernet/arp at all during Firmware/UEFI environment/runtime...
2) No matter how I configure the Minix (WOL enable/disable, CPU Power Technology, Minix Feature Configuration, et al) the switchport stays in operational status "up" for as long as I have the power supply connected to the Minix. Normally, a switchport goes into operational status "down" as soon as the connected device is shut down or has not yet been booted since the psu got connected (except for when WOL is activated and the device/BIOS keeps the connection up to listen for WOL packages)...

Minix Dev-Team/Core Team/Support Staff, any help/input?
 

notrui2

Trusted Helper
#5
I dont have any experience of booting a OS by network and i never done that.
What you can do is trying with another OS image if you can, or change something in the server.

You must eliminate options by testing.

I dont know if the problem is in minix device or some hardware/software between them.
 
Last edited:

notrui2

Trusted Helper
#6
I will read more and watch youtube videos about this ☺.
I like this ☺ and if i can i will also test myself (another OS and another device)

I thought of this a time ago, it is useful also if we have to install a new OS , in this case by ethernet.

I tested before installing OS with a external hdd and it works well but the same with rj45 is much better.
 
Last edited:

mak

New member
#8
Well, out of curiosity and based on notrui2s comments/screenshots, on Tuesday I ordered an N42C-4. And - lo and behold - that one works right out of the box! The result is all good. With the N24C-4 showing the expected behavior/result, identical to all our other existing computers/devices capable of network boot/PXE.

So this clearly must have something to do with the Z83 and its Hardware/Firmware/UEFI readiness in relation to network boot/PXE... ...And can also not be a DOA case on one specific Z83 but rather a platform problem as all four Z83 Pros and Plus I tested showed the same behavior (I actually tested with two Z83 Pros and two Z83 Plus as we bought these as test devices in the hope to use them in a large company IT project. We want to replace all our existing Linux based Citrix Thin Clients with Windows based Citrix Clients. And we're talking about 300+ Citrix Users!).

Again, any input from Minix Team? @Minix - Martin? Or Is there any other way to get into serious support contact with Minix Development? Anything and everything points into this forum as the main place of help...

Interested in selling a rather large amount of Z83s? Or should we rather look into competition just because of lack of interest from the creator/product developer? Unfortunately, the N42C devices are not an option as they are not fan/noiseless.

Best regards, in hope to finally get a word from somebody out of the Minix Team.
mak
 
#15
Yesterday i made tests, read a lot about PXE.
i used serva:
https://www.vercot.com/~serva/

If i have PXE serva installed (free version) in win7 i can see the install menu in order to install the OS but if i have PXE serva in win 10 it does not work for me.
I only tested to see the menu to install , if i have the possibility i will test full installation.
I also watched youtube videos.
Now i know better how it works ☺, before i had a idea.

I tried other programs like tiny pxe server but it dont work for me.

I tested on 3 windows pc:
Two with win10 and one win 7.

I am thinking in installing PXE (if i can) in my Synology ds418 NAS , i know that is possible to install in a NAS.

Ideal was just using iso files (in NAS for example) and install (from network to clients) .

I think today i will try install PXE in a virtual machine , it is way to get full installation ☺

I like this and i will test and read more ☺
 
Last edited:
#16
@MINIX – Martin
Thanks for the feedback - I also got your E-Mail from support@minix.com.hk yesterday

This is unfortunate. And leaves me in a bit of a lost situation. But, well, live goes on :) We'll see if we find a different solution using the z83 hardware generation for our project as we all quite like the product otherwise.

@notrui2
Thanks a lot for your involvement! Depending on what you want to accomplish with PXE (automated machine staging or os streaming), the technology can be a bit cumbersome and fiddly. But it is a lot of fun and teaches loads of Networking and basic operating system knowledge (DHCP, OSI model, ARP and TCP/IP, os boot process and kernel environment preparation). I wish you a lot of fun on your journey :)

Case closed.

P.S. maybe the info that the z83 hardware generation is not PXE compabible could be pinned/posted in general knowledge articles and forum entries? So people interested in this find the info a bit faster than me...
 
Top