NGC-1 Replace SSD

#1
Hello guys.
My MINIX is NGC-1. After replacing the ssd I tried to clean some "extra" partition from the disk and probably I deleted some important files. What is happening? The machine only starts in shell prompt mode. Windows can start via the shell path: EFI / BOOT / bootx64.efi. It is, with manual typing only. In BIOS(uefi) lacks the ability to add other boot options than efi shell. I guess missing the windows boot manager, but I don't know how to fix that. What options do I have to decide the problem?
Does the next link to last firmware will solve the problem?
http://www.theminixforum.com:9009/firmwares/NGC-1-V01.7z
What does this firmware actually contain?
I will be grateful for your help. I apologize for my bad English.
 

Villa

Administrator
#2
Hello guys.
My MINIX is NGC-1. After replacing the ssd I tried to clean some "extra" partition from the disk and probably I deleted some important files. What is happening? The machine only starts in shell prompt mode. Windows can start via the shell path: EFI / BOOT / bootx64.efi. It is, with manual typing only. In BIOS(uefi) lacks the ability to add other boot options than efi shell. I guess missing the windows boot manager, but I don't know how to fix that. What options do I have to decide the problem?
Does the next link to last firmware will solve the problem?
http://www.theminixforum.com:9009/firmwares/NGC-1-V01.7z
What does this firmware actually contain?
I will be grateful for your help. I apologize for my bad English.
The firmware is Windows 10. Which version I'm not sure? Most definately not the latest!

Did you clone the original SSD to the new SSD?
 
#3
----------- To Villa ----------
No. I didn't have a usb to m2 converter for cloning. For windows installation I made bootable usd flash drive. Everything was easy, but I created unnecessary partitions. Then I decided to clean them and maybe "cleaned" some system partition. Windows works by itself well, but every restart it enters in shell prompt (EFI Shell). There is no option in bios boot menu to select other boot option. There is only one possibility and that is EFI Shell.
 
Last edited:
#4
The firmware is Windows 10. Which version I'm not sure? Most definately not the latest!

Did you clone the original SSD to the new SSD?
Thanks Villa for response,
Do you think a clean installation of windows can solve the boot problem?
And other. What does this zip file contain? Is it an ISO image?
Is it need license key for Win10?
I saw same case like mine here:
https://theminixforum.com/index.php?threads/partitions.2546/
I made same mistake.
 
Last edited:
Top