Which Kodi or similar can I install? Please answer to me

#8
Android 4.4.2 is KitKat which has an API Level of 19.

Kodi Krypton will need >= Android 5.0 which is API Level 21

Kodi leia (18) is even more recent.

Your Neo x7 has kit kat.

This i said is for official Rom (kitkat), you can try this custom ROM:
https://theminixforum.com/index.php?threads/lollipop-wasser-firmware-3-0-6-for-minix-neo-x7.248/
Sarkari Result Pnr Status 192.168.l.l
With lollipop (android 5) you can install kodi 18.2, latest one.
i tried to install kodi 18.2 on lollipop
 
Last edited:
Top