ITV Player

#1
I have a Minix NEO-U9 with a number of media apps installed. I connect to the UK from Middle East (using VPN) and recently ITV Player stopped working saying that I was using wrong version of Android. The Minix NEO-U9 currently has 6.0.1. Has anyone run into similar issues and how were you able to resolve? I've looked for similar threads and cannot find in this forum.
 
#4
Your version will need an update, that might be difficult to get as I find here in Asia Google Playstore will not allow you to update outside the geolocated area. I have overcome this issue using Aptoid they did have a dedicated install that I found when searching for a solution, however their app has it available .. you will need to search within it, also available is the All4 that some seem to have issues getting.
 
Top