NEO U22-XJ: 007 FW 20210923 OTA - Black screen on reboot

#21
Guys, try to be patient when you get to the black screen. I did ponder whether it crashed as well when I got to this point, but after 5 to 10 minutes of leaving do its stuff, the box rebooted successfully.
So my advice would be to give it some time, as power cycling/rebooting might do more harm than good.
Of course, if it has been going on for an hour or so, I don't expect that's normal.
IIRC, the update was dated 23/09, so if there's a public beta V007 dated 20210824, then personally I'd rather flash back to 006A and then let FOTA bring it back to the official v007.
 
#23
SOLVED problem with black screen after Fota Update. Using the Reset Button, then on the Recovery Menu choose enter Wipe Data/Factory Reset. Then System Reboot. At the end, the system turns back to the Minix Metro interface. And with the new 007 software version installed!
Thanks anyway.
Step by Step please
 
#24
Step by Step please
It's already step by step:
- Get to the recovery mode by pressing and holding the reset button few seconds while powering the box on. Detailed instructions here:
https://theminixforum.com/index.php?threads/minix-neo-u22-xj-how-to-enter-the-recovery-menu.2787/
- In the Recovery Menu, choose Wipe Data/Factory Reset.
- When done, still in the recovery menu, choose System Reboot.
- The system turns back to the Minix Metro interface with the new 007 software version installed.
 
Last edited:

dak7385

Active member
#25
Because as far as we (Not MINIX staff) are aware it has not been fully tested!
Surely if it is on FOTA, it should indicate an official release. But happy to be advised. If this is released by FOTA and not fully tested, I will revert back to FW006A. Or, do you recommend leaving it at FW0007?

I have used the FOTA for FW007 and really cannot see a difference to any of the bugtracker reports/ faults from the previous version.
 

dak7385

Active member
#27
Leave it, what @Villa was trying to say is we (forum staff) have been left in the dark by the Minix staff regarding how fully tested this firmware is. If they have released it via FOTA then we can only assume it is good to go.
Many thanks Marty. That all makes sense now. Don't understand what Minix are playing at. Minix forum staff do so much for Minix, and are inexplicably now left out of the loop in important matters. They really need to sort out their act.
 

Villa

Administrator
#28
Surely if it is on FOTA, it should indicate an official release. But happy to be advised. If this is released by FOTA and not fully tested, I will revert back to FW006A. Or, do you recommend leaving it at FW0007?

I have used the FOTA for FW007 and really cannot see a difference to any of the bugtracker reports/ faults from the previous version.
Usually we get asked to test FOTA before it goes public. We ask questions behind the scenes to no replies! :mad:
 
#30
After I did reset .... I lost all data ... I lost one morning of my Sunday ..... I put all my apps back ... Now after turning them off .... Black screen again. ... Now I'm really angry ... Very angry
 
#31
After I did reset .... I lost all data ... I lost one morning of my Sunday ..... I put all my apps back ... Now after turning them off .... Black screen again. ... Now I'm really angry ... Very angry
Yes, doing "wipe data" can fix a system not booting, but it of course means you lose your data.
You should still be able to revive your box to FW006A by following the "Manual installation" section from the first post in this thread:
https://theminixforum.com/index.php...w-20210203-bugtracker-ota-now-available.3722/
It requires connecting your box to a PC with the USB cable provided, and installing/running "Amlogic USB Burning Tool v2.2.0" on the PC.
 
#32
Yes, doing "wipe data" can fix a system not booting, but it of course means you lose your data.
You should still be able to revive your box to FW006A by following the "Manual installation" section from the first post in this thread:
https://theminixforum.com/index.php...w-20210203-bugtracker-ota-now-available.3722/
It requires connecting your box to a PC with the USB cable provided, and installing/running "Amlogic USB Burning Tool v2.2.0" on the PC.
Yes I know ... But all this can be possible with a 20/50 euro box ... With a 180 euro top .... With a few updates .... Then one more thing ... It is written on amazon processor speed 2.0ghz ... but it stopped at 1.7 .... false advertising like dolby vision ..... Excuse my outburst .. But today is what made me nervous ... Tomorrow will spend the sun inside about me ... And I'll be patient as always
 
#33
Yes I know ... But all this can be possible with a 20/50 euro box ... With a 180 euro top .... With a few updates .... Then one more thing ... It is written on amazon processor speed 2.0ghz ... but it stopped at 1.7 .... false advertising like dolby vision ..... Excuse my outburst .. But today is what made me nervous ... Tomorrow will spend the sun inside about me ... And I'll be patient as always
Yes, not blaming you. Personally I don't use dolby vision, but I can see why that would be a problem, especially if it doesn't get fixed. There was a changelog with FW007 in the FOTA screen, but I didn't think of taking a screenshot, so not sure what was addressed.
What bothers me the most is that the A3 remote eats batteries when not in use, so I have to take them out!
As for the CPU speed, I can try to run AIDA and see what it says in FW007.

*EDIT* AIDA64 says:
2x ARM A53 @ 1800MHz
4x ARM A73 @ 1704MHz
So it doesn't sound like FW007 will address your concern about CPU speed.
 
#37
What bothers me the most is that the A3 remote eats batteries when not in use, so I have to take them out!
I seemed to have solved my A3 battery consumption problem since buying a Panasonic BQ-CC55 charger and 4 x eneloop BK-4MCCE 5 months ago, and am hoping it might have fixed it for 5 years at least now, given eneloop's claims https://en.wikipedia.org/wiki/Eneloop
 

Attachments

#38
Thanks, I did think about putting some rechargeable, but then I don't use the box often so didn't want to find out they needed charging every time I need the remote.
In the meantime, I cut some tabs from a milk bottle, and insert them on the + side of the battery (like what you find on batteries installed in new devices).
 

Villa

Administrator
#39
#40
Thanks, I did think about putting some rechargeable, but then I don't use the box often so didn't want to find out they needed charging every time I need the remote.
In the meantime, I cut some tabs from a milk bottle, and insert them on the + side of the battery (like what you find on batteries installed in new devices).
My battery consumption problem has been from having a succession of A3's in use for probably at least 6 hours most days for the last 4+ years until this black screen episode, but what concerned me even more than battery consumption was my A3 remote consumption, that repeatedly suffered from central 'Android' button 'dome switch' failure after about ~8 months from new, which from my usage, I calculated is probably about their design life of ~1 million cycles, but have had great success with transplanting little used dome switches from a donor A3 remote to the central 'Android' switch position, and fixing them in place with a bit of the adhesive tape from the donor remote.
 

Attachments

Website:http://minix.com.hk
Facebook:  facebook.com/minixtech
Telegram Channel: t.me/minix_channel
Telegram Group:    t.me/minix_group

Top