BBC Iplayer problem on U9-H

#1
This problem has just started, loading BBC Iplayer goes OK until i select a programme to watch, what happens then is the picture comes up OK, there is a fraction of a movement of whatever programme it is and then the screen freezes. The audio keeps running OK. I have tried removing and reloading Iplayer, no change. The ITV player works OK. I have the same BBC Iplayer on my phone, Lenovo pad and on Bluestacks. The BBC Iplayer works on all these OK. All systems are running Android. Any ideas please? Forgot to say i am in Spain using the same VPN for all systems
 

Villa

Administrator
#2
This problem has just started, loading BBC Iplayer goes OK until i select a programme to watch, what happens then is the picture comes up OK, there is a fraction of a movement of whatever programme it is and then the screen freezes. The audio keeps running OK. I have tried removing and reloading Iplayer, no change. The ITV player works OK. I have the same BBC Iplayer on my phone, Lenovo pad and on Bluestacks. The BBC Iplayer works on all these OK. All systems are running Android. Any ideas please? Forgot to say i am in Spain using the same VPN for all systems
I'm in Spain too and not having issues with BBC iPlayer. But I use a SmartDNS service!
 
#4
I am having the same problem with BBC iPlayer. All my other TV streaming apps are working fine. But in the last two days BBC iPlayer app won't show moving video. Just freezes and carries on playing the audio. UK resident, no vpn active. What have they done? My kids are going to be very unhappy if I can't fix this! Firmware U9-H FW008 20180209
 

Villa

Administrator
#5
I'll double check how it's performing for me on the U9-H.

To be honest last week I put the U9-H to one side to concentrate on using the U22-XJ.
So if anything has changed since I won't have seen it, but my in-laws are still using their U9-H (FW001 Android 7 CE) and BBC iPlayer.
I can assure you, if they have issues I am the first to know! :giggle:;)
 
Last edited:

Villa

Administrator
#6
Hi Villa i use Smarty VPN/DNS on all devices, only this box has started to give the problem.
Did you see the private message I sent you?
It may not be the VPN/DNS service you use that is the issue as you say iPlayer works on other devices but you may like to try what I suggested and it may even be cheaper!
 
#7
I am having the same problem with BBC iPlayer. All my other TV streaming apps are working fine. But in the last two days BBC iPlayer app won't show moving video. Just freezes and carries on playing the audio. UK resident, no vpn active. What have they done? My kids are going to be very unhappy if I can't fix this! Firmware U9-H FW008 20180209
Hi Jonesdude, have you found a fix yet, i also find that bbc1/2 etc work ok on Iplayer. is that the same for you. I think it is something wrong on the U9-H stopping or interfering as the Iplayer is ok on other equipment, also ITV player runs OK.
 
#8
Did you see the private message I sent you?
It may not be the VPN/DNS service you use that is the issue as you say iPlayer works on other devices but you may like to try what I suggested and it may even be cheaper!
Hi Jonesdude, have you found a fix yet, i also find that bbc1/2 etc work ok on Iplayer. is that the same for you. I think it is something wrong on the U9-H stopping or interfering as the Iplayer is ok on other equipment, also ITV player runs OK.
It has nothing to with VPN as i have tried another VPN and it is the same, must be someting on U9-H interfering.
 
#9
Hi Jonesdude, have you found a fix yet, i also find that bbc1/2 etc work ok on Iplayer. is that the same for you. I think it is something wrong on the U9-H stopping or interfering as the Iplayer is ok on other equipment, also ITV player runs OK.
I just started from a fresh boot up. It worked fine for the first item I played. Then all subsequent videos froze. However if I return to the first video then that one DOES play again fine. Some of my settings: I am connected via ethernet. Location is on. WiFi is turned off. I'm baffled as to what it could be.
 

gdf

Active member
#10
Solution: you need to have installed iPlayer V 4.94 and the problem will be resolved ... if your version is higher than that then you will need to uninstall it first, the version I refer to is available on APK Pure, if you use this app you will know it offers updates to your existing apps when available. however to get the iPlayer app just type in the search bar "BBC iPlayer" and a list will generate with the icons showing .. DO NOT install the version being offered instead click on the iPlayer icon displayed on the left hand side and a new window will open giving details regarding the app you may have to scroll down a little to find on the left a heading stating VERSION HISTORY .. click on that and the second one down from the top as I write is V 4.94 .. the top one being the one that is causing the issue ... so providing your version is previous to v 4.94 go ahead and update ... if your version is higher then you can ask it to update but it will fail .. however it will have downloaded the version in the downloads folder of your Minix .. I have resolved the issue on 40 plus over the past two days and it is an easy process to achieve .. I also clear the cache if I have uninstalled the app prior to the installing v 4.94 ..
 
#11
Thank you GDF that has worked for me. Maybe one day the app will be updated again and I can go back to the play store version. But this works fine now for me. The only thing I didn't know how to do is 'clear the cache'
 
#12
Solution: you need to have installed iPlayer V 4.94 and the problem will be resolved ... if your version is higher than that then you will need to uninstall it first, the version I refer to is available on APK Pure, if you use this app you will know it offers updates to your existing apps when available. however to get the iPlayer app just type in the search bar "BBC iPlayer" and a list will generate with the icons showing .. DO NOT install the version being offered instead click on the iPlayer icon displayed on the left hand side and a new window will open giving details regarding the app you may have to scroll down a little to find on the left a heading stating VERSION HISTORY .. click on that and the second one down from the top as I write is V 4.94 .. the top one being the one that is causing the issue ... so providing your version is previous to v 4.94 go ahead and update ... if your version is higher then you can ask it to update but it will fail .. however it will have downloaded the version in the downloads folder of your Minix .. I have resolved the issue on 40 plus over the past two days and it is an easy process to achieve .. I also clear the cache if I have uninstalled the app prior to the installing v 4.94 ..
Thanks very much gdf, works a charm V4.94, why on earth don't these companys check their updates out prior to issuing them?
 

gdf

Active member
#16
If you are unsure google the question ... I did on your behalf and the following was returned.

"Like APKMirror, the site abides by rigorous security practices to make sure all the APKs you download are safe and virus-free. APKPure verifies the legitimacy of all apps before publishing by using SHA1 to ensure the certificate is safe. ... APKPure also has an Android app available. (Dec 6, 2019)"

The BBC has a vested interest to keep its business safe and needs to be seen doing so for reasons of compliance .. I also have backed up versions of what I consider important apps .. However from version 4.71 there have been compulsory updates required by the BBC... so my collection as Villa"s is relatively useless.
 
#17
Unfortunately the problem has returned after running OK for a day. Tried to reload v4.94 but now says i must load latest version which we know locks up picture, audio OK. Does anyone know how to stop BBC Iplayer updating?
 

gdf

Active member
#18
V 4.96 has just been released and is working fine ... seems they have addressed the fault.. I installed from APK Pure ... on to T5 .. I have no reason to doubt it will be any different on the U1 .. U9-H or U22-XJ
 

gdf

Active member
#20
Well I have just tested the v4.96 on a U22-XJ and that works .. I have just tested on a U9-H and v4.96 does not work ... I have reinstalled v4,94 and it is working on the U9-H .. SO .. T5 is OK on v4.96 as is U22-XJ.. I don't have access to a U1 but hopefully today I will get one in for an update.
 

Website:http://minix.com.hk
Facebook:  facebook.com/minixtech
Telegram Channel: t.me/minix_channel
Telegram Group:    t.me/minix_group

Top