[SOLVED] Replace custom firmware with stock? X68i (Industrial)

#1
I was given a Minix box that appears physically to be either a U1 or a U9. There are no labels on it that indicate which it might be, but from looking at the available ports it appears to be one of these.
When the device boots, it automatically starts an App called Interalia and plays some onboard music file.
I want to flash this with a stock, Minix firmware.
The burning tool does not appear to recognized the device, yet when I boot using the pin and use ADB Sideload, the latest U1-FW013-Android_5.1-20170629-USB_Stick file does start to transfer and at about 35% load there is an error that the signature is incorrect and aborts.
The existing firmware version shows Android 5.1.1 from 2016.

Any ideas on how I can flash this box in to something usable?
 

ArcticWolf

Trusted Helper
#2
I was given a Minix box that appears physically to be either a U1 or a U9. There are no labels on it that indicate which it might be, but from looking at the available ports it appears to be one of these.
When the device boots, it automatically starts an App called Interalia and plays some onboard music file.
I want to flash this with a stock, Minix firmware.
The burning tool does not appear to recognized the device, yet when I boot using the pin and use ADB Sideload, the latest U1-FW013-Android_5.1-20170629-USB_Stick file does start to transfer and at about 35% load there is an error that the signature is incorrect and aborts.
The existing firmware version shows Android 5.1.1 from 2016.

Any ideas on how I can flash this box in to something usable?
Was the box fully bootable when you received it?
 
#3
If the box is booting into android, then you could eliminate all user installed apps by doing a factory reset.

On the bottom of your minix box there should be 2 silver barcode labels. On one of those labels the device should be identified above the barcode.
 
#4
Was the box fully bootable when you received it?
The box boots then automatically runs the Interalia App. It allows me access to swipe down and access System.
I can find the App, Force Stop it, Clear Cache, Clear Data but there is no option to Disable or Uninstall.
There is no Play Store installed.
Performing an Android Factory reset does nothing.
Booting into recovery (pin in the bottom), then performing a factory reset, on the next boot takes a long time but the box restores itself to the same point.
This is why I'm fairly sure that it is a custom firmware load that is going to require re-flashing with a stock image.
 
#5
If the box is booting into android, then you could eliminate all user installed apps by doing a factory reset.

On the bottom of your minix box there should be 2 silver barcode labels. On one of those labels the device should be identified above the barcode.
As I said, there are no labels on the box at all. I am comparing plastics and ports to try to determine which model it is.
Factory resets do not resolve the problem.
 

Villa

Administrator
#6
As I said, there are no labels on the box at all. I am comparing plastics and ports to try to determine which model it is.
Factory resets do not resolve the problem.
On the underside does it say, "Quad Core Media Hub" and the power rating and some more stuff?
If so, above, but below the Android Man, does it say MINIX?
 

ArcticWolf

Trusted Helper
#8
The box boots then automatically runs the Interalia App. It allows me access to swipe down and access System.
I can find the App, Force Stop it, Clear Cache, Clear Data but there is no option to Disable or Uninstall.
There is no Play Store installed.
Performing an Android Factory reset does nothing.
Booting into recovery (pin in the bottom), then performing a factory reset, on the next boot takes a long time but the box restores itself to the same point.
This is why I'm fairly sure that it is a custom firmware load that is going to require re-flashing with a stock image.
Certainly sounds like a custom ROM, yes.

Presumably, looking through the device's "about phone" in the settings doesn't state what the device actually is with this mystic custom ROM?

However, I think @Villa is on to the easiest way to determine them apart :).
 
#9
On the underside does it say, "Quad Core Media Hub" and the power rating and some more stuff?
If so, above, but below the Android Man, does it say MINIX?
MINIX is molded in to the top lid.
On the bottom there is light blue stenciling that says MINIX, Quad Core Media Hub, Rated 5V 3A max, Designed by MINIX, Assembled in China
 
#10
I suspected U1 which is why I used that stock firmware load in the ADB Sideload but it failed signature while transferring.
Might add, oddly enough if I do a: ADB DEVICES, the box response is.... 1234567890ABCDEF
 
Last edited:

ArcticWolf

Trusted Helper
#11
I suspected U1 which is why I used that stock firmware load in the ADB Sideload but it failed signature while transferring.
Might add, oddly enough if I do a: ADB DEVICES, the box response is.... 1234567890ABCDEF
Read here - https://theminixforum.com/index.php?threads/u9-h-update-serial-number.336/

I can't comment on the U1 & whether they had this issue as I've never owned one. However, the generic serial number was a known issue with some U9-H's. I have access to at least two U9-H's that both have the "0123456789abcdef" serial numbers. (I've never bothered to adjust mine accordingly & it hasn't ever affected their performance, installation or availability of apps, Play Store access, etc., etc., etc.)

The U9-H is definitely 0123456789abcdef. Is yours 1234567890abcdef or 0123456789abcdef?

Were there U1's with this "generic serial number" issue as well that you know of @Villa?
 
#12
I'll add that I have no fear with this box. It was free and I have plenty of in-house capability to stream so if I brick this MINIX box, it was a just a tech thing to play with and learn from.
The gloves are off if anyone has any extreme ideas.
I'll give the U9 serial number fix thing a go tomorrow and post results.
I have no idea what might be used for signature validation but could be a valid serial...... guess we'll find out.
 
#16
Yea sorry about that, real business got in the way.
So a few things.... The package and process suggestion supplied by Finless at Freaktab doesn't work.
First, holding the power button in didn't do anything. The blue power light comes on for a couple of seconds, goes out and the box does nothing, I held the power button in for two minutes and nothing happened.

I booted in to recovery mode and the SD Card is being recognized. Normally when I go in to Recovery with the slot empty I see errors that Drive E is empty and not loaded. I'm not getting that error with this SD Card in.
There are no options in the recovery mode menu to load updates or images from the SD card.

I performed another wipe/reload/factory reset and this time when Android reloads in System Info it's now saying Model NEO X68-i, that field was blank when I checked it before.
I haven't seen this model listed but I did look at the X6 and the ports are not the same.
Just started a Google search on this model but thought I'd get this update out now.
 
Top